I updated to Thesis 2.1 and now my site is broken.

If you’re using a third-party skin, and/or any third-party boxes, they may not be compatible yet with Thesis 2.1, and fatal errors can occur as a result. Your options are:

1) continue using Thesis 2.1, but suspend your use of the third party skin or box until the developer releases a 2.1-compatible update; OR

2) revert to Thesis 2.0.3.1, and continue using the third party skin or box until its developer releases a 2.1-compatible version (at which point, you can then update to Thesis 2.1).

OPTION 1: Continue using Thesis 2.1

You will need to disable the third party skin or box by renaming its folder on your server:

  1. Login to your server via FTP.
  2. Navigate to the /wp-content/thesis folder in your WordPress installation, and expand it.
  3. To disable a skin, open the skins folder; to disable a box, open the boxes folder.
  4. Locate the folder related to the skin or box which has caused the error(s) on your site.
  5. Rename the folder (for example, by appending _OLD to the end of its original name).
  6. Refresh your site and/or WordPress Dashboard in your browser, to confirm that any errors have now gone away.
  7. If you disabled a skin using this method, go to Thesis Home > Skins > Manage Skins, and activate the Thesis Classic Responsive Skin.

Once the third party developer has released a 2.1-compatible update to their skin or box, follow their instructions to install the updated version, and then you can begin using it with Thesis 2.1.

OPTION 2: Revert to Thesis 2.0.3.1

You will need to manually install the older version on your server by using FTP:

  1. Download the .zip file by clicking here.
  2. Extract the .zip file to obtain the thesis folder.
  3. Login to your server via FTP.
  4. Navigate to the /wp-content/themes/thesis folder in your WordPress installation, and expand it.
  5. Upload the contents of the thesis folder on your computer to the /wp-content/themes/thesis folder on your server (replacing everything which is currently there).
  6. Go to Appearance > Themes in your WordPress Dashboard, and make sure that Thesis 2.0.3.1 is the currently active theme (if not, then activate it).

Once the third party developer has released an update to their skin or box, and you’re ready to upgrade to 2.1 again:

  1. Go to Thesis Home > Skins > Select Skin, and activate the Thesis Classic Skin (NOT the Thesis Classic Responsive Skin).
  2. Look for the yellow update nag message on your WordPress Dashboard, and click it to update to Thesis 2.1.
  3. Install the updated, 2.1 compatible skin or box from your 3rd party developer.
  4. If applicable, go to Thesis Home > Skins > Manage Skins, and activate the newly updated skin.
  5. If applicable, go to Thesis Home > Boxes > Manage Boxes, and activate the newly updated box.